Repair: Soyoung S-C18 Soymilk Maker

This weekend, a friend of ours had a small emergency – her soymilk maker stopped working and was completely dead. The particular unit was a Soyoung S-C18 which claimed to be a unit specially made by Joyoung for the Australian market. Accordingly, it seemed to have the appropriate regulatory labels and claimed to be for 240V input – definitely something which we appreciate as many Chinese appliances which are 220V rated tend to fail early. This unit had already run for five years and had definitely done its time, being used at least weekly. Having to buy a new unit was a distinct possibility, but as usual, we are reluctant to dispose of anything until the cause of death is found or we have determined that it would be uneconomical to repair.

The Unit

The unit looks a little like a jug from the side, with some gold accents on a white body.

But once you look at the top, you realise it’s something more sophisticated. There is a sturdy handle and the top panel has a few buttons and clear areas for LED indicators to shine through. On the side, there is an input for an IEC kettle lead.

Pulling out the top unit, we find the bulk of the weight in this section. There are sensor stalks – one for water level, another for boil-over detection and a hidden temperature sensor. The plastic top section joins to a guard …

… which covers the blade and serves to “funnel” the beans into the blade in order to ensure a smooth result. After all the accumulated use, the blade and several other sections exhibit some staining.

The top unit detaches completely from the base but has a four-pin electrical connection with the base. This is because the IEC lead goes into the base, and the base itself also contains a heating element to boil the liquid from below. As a result, I’m guessing there’s a live, neutral, earth and switched heater output that comprises the four connections.

The plug goes into the corresponding socket in the handle and that’s about all there is to see. I’ve never seen or used a soymilk maker, so this was a rather new experience.

Teardown Diagnosis

Before even opening the unit, I felt its prospects may be quite limited. Just rotating the top unit resulted in some rattling noises, which I suspected meant that there were blown component parts jostling about. Many times, this indicates a catastrophic failure with some possible collateral damage. The only way to confirm this was open surgery.

Luckily, the unit is made with screws – these line the perimeter where a silicone gasket seals the top. Unscrewing a large number of screws frees the trim and the top part from the base. Immediately, black gunk spills out and the inside is ashen.

There was evidence of water ingress, as the screws for the top control panel and controller module had rusted quite visibly. Because of this, I decided it was not a good idea to open that section unless everything else checked out, as the screws would almost certainly crumble.

The gunk that spills out looked rather dark, like charcoal, but had a very rough shape and didn’t resemble any component. Seeing that there was a motor, I wonder if the motor had burnt out and brush segments were being thrown everywhere. A seized motor could cause a fuse to blow, resulting in the “dead” symptom.

The first card I paid attention to is this power control board.

Dated Week 20 of 2013, it marshals power around the unit – supplied with mains, forwarding that onto a transformer, receiving power from the secondary, rectifying and regulating it, sending it to the controller top panel and containing relays that switch the power to the remaining components (e.g. heater, motor). It also has a beeper for feedback. The carbon coating was quite severe, with the white “ice cube” relays being turned into a dark grey. Parts of the board, especially the underside, was coated in silicone conformal as if they anticipated moisture ingress, in order to prevent any possibility of short circuits. However, such a carbon coat is concerning as it could provide enough conductivity for a “flashover” or tracking, with occasional complaints of RCD tripping pointing towards a fault within this appliance.

That being said, I spotted no missing components and nothing obviously stressed. A good start, although I couldn’t be certain that the relays hadn’t welded. But because of the conformal coating, I couldn’t test them easily, so I left them alone. I tested the onboard fuse in the shrink wrap – it was still continuous, which is another good sign that the unit didn’t go thermonuclear.

Onto the next board on the side and this is merely just a motor EMI filter board. This is connected in-circuit with the motor using spade connectors and seems like it could be omitted for cost savings in some other markets. Regardless, I tested across the unit and it was showing continuity as well – so the filter didn’t burn out.

Moving down to the transformer, this was a “classical” E-I core transformer. Linear transformer bricks are almost as reliable as bricks, so I didn’t expect much to be wrong, but there was slight corrosion on the steel consistent with moisture exposure. To be safe, I decided to check both coils were continuous and that was when I realised that the primary was open! This seems likely to suggest a thermal fuse may have tripped, so why did it fail? Was it something that had failed on the secondary, keeping the secondary shorted?

The loss of this transformer will cause a dead unit as this unit is responsible for producing the supply that runs the controller and relays. The transformer has a strange 240V to 11V rating at 160mA – I suspect this may have been a relabelling of a 220V to 10V transformer, but because of its strange rating, it seems almost impossible to get a direct replacement. However, it does suggest that it could have been running a bit warm because the higher AC voltage in Australia would cause higher amounts of core saturation.

This still leaves the carbon chunks and gunk unexplained, so I went further in disassembling. For this, I needed to get the motor out, which required removing the blade funnel, undoing the captive nut, removing the blade and washers, then removing two screws, a protective plate, a gasket and another two screws from the front.

The result was this 180W motor from Wolong Electric Group which had slightly unsmooth rotor bearings, a smooth commutator with sufficient brush carbon remaining and lots of gunk.

Looking from the front, especially where the motor fan is, there is evidence of water ingress, rust and accumulation of soy bean which is in various states of dryness – from brown paste through to black goo and black “hard” lumps. With some careful prodding, I was able to dislodge the majority from the motor without damaging the windings.

Given all the evidence, my hypothesis is as follows:

  • Earth leakage breaker trips occurred on this unit primarily due to liquid from the soy milk chamber being drawn up the motor spindle due to capillary action especially near the bearings as well as due to temperature changes due to heat causing steam to be inducted as well. This liquid contains suspended solids which remain behind in the motor assembly and accumulate over time while the water slowly evaporates and dissipates, possibly assisted by the heat of the motor operating in an enclosed environment. Between cycles, some of this accumulated solids dry out sufficiently and combine with the loose carbon evolved from the wearing of the brushes against the commutator and rattle “freely” within the upper unit. The solids that do not, however, can re-accumulate new moisture on a run, which causes a possible bridge of the rotor winding current (e.g. through a nick in the enamel insulation) to ground (the motor chassis) – if the leakage current is high enough, then the earth leakage breaker trips.
  • An alternative explanation would be due to carbon accumulation and tracking. A minor flash could have occurred in the past clearing the conductive path temporarily.
  • The transformer itself may have been a 220V unit relabelled and may have been running hot. As the top unit is sealed, all the heat generated is not easily dissipated especially since the boiling liquid is underneath adding heat into the unit during a cycle. The accumulated heat could lead the transformer to operate close to 100 degrees C throughout its life, stressing the thermal fuse in the primary winding. This would eventually open resulting in a loss of power to the control board, resulting in a seemingly dead unit.

From looking at the design, it’s actually a very tough environment to operate in and the design has a number of downsides. The sealed environment causes heat accumulation which would stress electronic components and even the motor itself. A brushed motor generates carbon dust which is conductive and can cause tracking or short circuits – with a sealed unit, the dust has no chance to escape (unlike in a power tool for example). The remaining components go through severe thermal stress in each cycle. Given the large air void and sealing gaskets, it is inevitable the air will be “purged and sucked back in” in every cycle which would encourage liquid ingress. Further, the motor’s rotating shaft has to go right into liquid through a bearing – another area where liquid ingress is inevitable. As a result, it seems the design was made with a few features to make sure it would last long enough to survive the warranty period … but not indefinitely.

Repair

Owing to the short “overnight” timeframe I had with the unit to repair it, I didn’t take many images, but the repair process was a multi-step procedure.

The first was to clean the motor and check its insulation resistance using my Keysight U1461A. Measuring from both poles to the grounded frame, a consistent 66Mohms was recorded in the “dry” state. While this isn’t the best reading, it’s still sufficiently high enough to declare the motor safe to use.

The next step was to attempt to ascertain whether the controller was still alive. I analysed the circuit and determined that the power marshalling board takes the AC from the transformer and puts it into a full bridge rectifier made of four discrete diodes (and then does more regulation). As a result, I felt it was safe to apply DC in any polarity at an appropriate voltage. Using my Keysight E36103A Benchtop Power Supply, I applied 9V DC and saw the top panel light up and the beeper emitting a continuous tone. The current consumption was 50mA or thereabouts, which left me satisfied that the control board had not completely died, but not knowing how to use the unit and not being able to activate it with any buttons (to check the relays), I decided it was worth repairing further to test.

I obtained an old 12V 400mA DC power supply from my wall wart junk box and gave it a good squeeze in my bench vise. This freed the transformer, to which I desoldered the rectifier and joined the original wires to, followed by a layer of heatshrink.

While 12V is slightly higher than the 11V and 400mA rating under 50mA load will probably result in an even higher voltage, this was “available to hand” at almost nil cost, so was the preferable choice compared to trying to obtain this 9V (lower) or 12.6V (higher) alternative from Jaycar. The upside of the Jaycar options is that it could probably be mounted correctly in the original holes – this one is a little larger, so I had to cut a little plastic. Not being designed to be mounted in the same way, it had no frame around it – so I had to glue it with hot glue and pad up the excess room at the top with bubble wrap as I expected the glue to soften in the hot state.

Once repaired in this way, the unit was quickly tested on my inverter current limited supply. It powered up to the same constant beep … which I suspected indicated an error. I couldn’t read the Chinese manual, but I suspected it was complaining of a lack of water. After filling the bottom, it powered up with a short beep and was ready to run. Success! As the inverter couldn’t handle the 700W heater and ~180W of the motor and control mechanism, I reassembled the unit for a full mains test but not before giving the insides a thorough wipe to try and clean off as much carbon deposit as I could.

After reassembly, we ran the unit with just water with some strange results. It did, however, give the unit a good clean. Afterwards, we ran it again with soy beans and it performed correctly – finishing a full cycle and giving us another jug of “fresh” soymilk.

Conclusion

I had never seen a soymilk maker, so having the chance to take it apart for repair was a new experience.

Ultimately while the unit was taken down by the loss of low voltage AC to the marshalling board and consequently the controller, the carbon build-up was potentially dangerous and the dried soybean residue at the front of the motor was likely to have been the cause of prior earth leakage breaker trips.

The concept of a soymilk maker designed in this way actually puts a lot of stress on the components and it seems quite impossible to ensure its reliability in the long term. The fact that we have had five years of service from the unit seems rather surprising given what was found within the unit – but after a repair, I suspect it won’t run for quite as long as the bearings will get worse, other components may become heat damaged, the brushes may become completely consumed and the gaskets may get looser resulting in increased liquid ingress rate.

At least this one lives to see another day …

About lui_gough

I'm a bit of a nut for electronics, computing, photography, radio, satellite and other technical hobbies. Click for more about me!
This entry was posted in Electronics and tagged , , , . Bookmark the permalink.

4 Responses to Repair: Soyoung S-C18 Soymilk Maker

  1. anonymous says:

    Hey, just came across your site.
    Seeing as you use WordPress, did you ever think to enable HTTPS to protect privacy and your password?

    Also you need a privacy policy due to Google AdSense and Google Analytics.

    • lui_gough says:

      Dear “Anonymous”,

      Yes, I have, and for the moment I have not enabled it because of a number of reasons which are somewhat interlinked – cost (as this is a personal hobby site which delivers close to 500GB of content a month at a budget of ~US$3/mo), load times (due to issues with CNAMEs and certain HTTPS certificate providers which restricts my ability to use CNAMEd CDNs) and complexity (especially if I go the low-cost CloudFlare Flexible-SSL solution where front end accesses are HTTPS and back-end accesses are not). While it is something I want to have in the future, at the moment, it is not a big priority. I am aware of the risk, however, I don’t exactly go posting to my site from untrusted connections either. It isn’t an easy choice, as my ranking has taken a hit due to not supporting HTTPS, but again, there are bigger priorities in life and I’m only a one-man-band.

      As for a privacy policy – this is something I might have to develop in the long run but is not a great priority at this time. As this is a personal hobbyist site (and I reside in Australia where it seems this is not an issue unless personally identifying information is being collected and being used or sold to third parties), no user signs up for an account and no such personally identifying data is requested from them unless they choose to voluntarily enter a comment, I’m not entirely sure how I’d go about phrasing one and/or the legalities surrounding it, nor do I think it is a major need.

      However, as you asked, I think this might cover a number of concerns:
      You visit this site at your own risk. No responsibility is accepted for any damages howsoever incurred – direct, consequential or otherwise. Information is provided in good faith, however, readers are advised to consult their own advisors, resources and expertise before embarking on any action (e.g. purchasing, building, trialling or testing designs).

      By visiting this site, data collection will be done by third party agencies (according to their rules) – this includes Google Analytics, Google Adsense (and their partners) as well as Automattic (Jetpack). As a result, cookies will be stored on your machine (if your browser is willing) and metadata about your visit will be collected (including but not limited to IP address, browser version, resolution, operating system, languages, resolution, visiting time, etc.), along with any data you choose to enter into forms (e.g. comments). Information is used for the purposes of providing analytics to the site owner, to provide the advertising services and comment services. A majority of this data is stored by the respective companies, with the exception of comments which is stored on my own database.

      Should you not wish to have this data collected, please ensure you have installed and enabled an ad-blocking or script blocking solution. Correct functioning of the site cannot be guaranteed under these circumstances. Do not enter any comment if you do not wish it to be published. All comments are moderated and once published, will not be removed, however private identifying information may be redacted by request (by contacting the site owner directly via the Contact Me page on the website). Data is likely to be shared by Google to third parties for provisioning of relevant advertising and for analytics, to which you may opt out of through mechanisms provided by Google.

      This may be subject to change in the future, as third-party provided services may change their operations and/or I choose to remove them from the site entirely.

      – Gough

      • sparcie says:

        People should know that HTTPS is not a guarantee of privacy, it simply is a mechanism to prevent man-in-the-middle attacks upon the data whilst it is in transit. There are many other ways that your privacy can and will be compromised, usually by the company handling your data or a security breach of some other nature.

        I believe we’re using HTTPS too much just for the feeling of being safer without much actual benefit. Much of our internet traffic has no need of being encrypted, an example being the public facing pages that anyone can access and don’t contain personal information. We’re basically chewing extra CPU cycles, power and bandwidth for not much more than a feeling. Which is in a way giving people a false sense of security.

        HTTPS does have an important place, it’s important for any kind of access to personal/confidential information and basic security on logins, but for freely available public information it’s just not needed.

        • lui_gough says:

          I wholeheartedly agree that HTTPS in itself is not a pancea to a lot of problems which stem more from business decisions more than anything else. HTTPS does have a cost – definitely CPU cycles, energy, latency with the TLS handshake translating into more time wastage, breaking local caching proxies etc. It is for a number of these reasons, to ensure widest compatibility and less hassles for myself that I haven’t yet made the transition.

          That being said, the weight to do so is increasing. Part of the reason is that non-HTTPS sites are suffering when it comes to search result rankings. Another is that there could be reputational harm if your site just so happens to be the one someone visited when they got MITM’d and infected or redirected elsewhere. While I have a certain level of trust for our ISPs in Australia, it seems that ISPs overseas are much more cavalier about tampering with data “in transit” and modifying HTML to inject advertising or tracking cookies (e.g. in the USA). For these people, I feel that it’s a bit unfair and while I do have sympathy for them, making the transition to HTTPS isn’t as trivial as it may seem as there are a number of tradeoffs I’ll be looking at to make it happen.

          That being said, when I do have the time at the nearest opportunity, just to ensure that I’m “legal”, I’ll make sure to get up a decent privacy policy/terms of use. It was something I had thought of but didn’t have the time to do … I never really thought it to be a problem until I got alerted.

          – Gough

Error: Comment is Missing!